Single Page Shopping

描述

Load woocommerce pages i.e. shop, cart, checkout, account and single product contents with ajax. With Ajaxify Store for WooCommerce, users will not have to wait for the website to reload when they do sorting or paging on archive products, add to cart from single product, view/update my account contents, update cart, proceed to checkout and place order. Sell from woo commerce store with any storefront and payments method with ajax woocommerce integration. Increase sales through automattic woocommerce shop with faster ecommerce cart, checkout and payment request. Setup regular e-commerce store or digital store with downloadable product for downloads with credit card.

Features

  1. Load archive pages (shop, category, tag) and other WC pages (cart, checkout, my account) with AJAX
  2. AJAX product sorting and paging
  3. Loading of single product with ajax
  4. Single product – ajax add to cart
  5. Submit product review with ajax
  6. Perform proceed to checkout with ajax
  7. Perform place order with ajax
  8. Load My account tab contents with ajax
  9. View and update my account content with ajax
  10. Save settings with ajax

屏幕截图

  • Plugin Settings corresponds to screenshot-1.png and screenshot-2.png.

常见问题

How to use this plugin ?

From Settings > Awcs, fill up “Target Element” input field. Target element is where ajax content will be loaded. It should be an unique element. Generally, it is the main content area of your website. For example, if you have an element “main” with id as content, then target element would be main#content or main(if unique in the page).

Where can i find plugin settings ?

Go to admin settings menu and then select Awcs

How to show product from specific categories ?

From settings, select categories you want in the “Select categories” field. You can leave out some products as well from “Exclude products” field.

How to remove duplicate ajax loading icon (if exists) on button click ?

Go to Awcs settings, select “Remove ajax loading icon” and save changes.

What are the pre-requisites to install AWCS ?

You will need to have woocommerce version at least 5.1.0, wordpress version at least 5.6, minimum PHP version required is 7.2.

评价

此插件暂无评价。

贡献者及开发者

“Single Page Shopping” 是开源软件。 以下人员对此插件做出了贡献。

贡献者

将“Single Page Shopping”翻译成您的语言。

对开发感兴趣吗?

您可以浏览代码,查看SVN仓库,或通过RSS订阅开发日志

更新日志

1.1.0

  • Added minified css and js scripts