Contribuinte Checkout

描述

With this plugin you can add VAT and VIES support to your WooCommerce store. The VAT field will be saved as ‘_billing_vat’.

Important: this plugin requires WooCommerce 3.0.0 or higher.
Warning: to enable and use VIES information you need to have SOAP extension enabled (SoapClient PHP class).

Features

  • Adds VAT field to billing form.
  • Adds VAT field to outgoing email.
  • Adds VAT field to checkout billing information.
  • Adds VAT field to admin orders page.
  • Change VAT field label and description.
  • Validate Portuguese VAT numbers.
  • Choose how to handle vat field validation errors.
  • You can make VAT field required.
  • You can add VIES information to admin order page, checkout and user billing page.
  • Adds settings page under WooCommerce menu so you manage all the features.

Translations

  • English.
  • Portuguese.

安装

This plugin can be installed via FTP or using the WordPress plugin installer.

Via FTP
1. Upload the plugin files to the /wp-content/plugins/woocommerce-contribuinte directory
2. Activate the plugin through the Plugins option visible in WordPress

评价

2022年1月31日
Este plug-in resolve muitas coisas, mas só lhe falta uma coisa para ser perfeito! Uma vez que a legislação obriga NIF's nas compras acima de 1000€, devia ser possível uma opção que obrigue NIF a partir de determinado valor. Assim a integração com o ERP Molini ficava perfeita.
阅读所有1条评价

贡献者及开发者

“Contribuinte Checkout” 是开源软件。 以下人员对此插件做出了贡献。

贡献者

“Contribuinte Checkout”插件已被翻译至2种本地话语言。 感谢所有译者为本插件所做的贡献。

将“Contribuinte Checkout”翻译成您的语言。

对开发感兴趣吗?

您可以浏览代码,查看SVN仓库,或通过RSS订阅开发日志

更新日志

1.0.43

  • New setting to make VAT field required on orders over 1000€
  • Tested up to version 5.9.1 of WordPress.
  • Tested up to version 6.2.1 of WooCommerce.

1.0.42

  • VAT number is now included in billing address container in emails and “thank you” page.
  • Tested up to version 5.8.1 of WordPress.
  • Tested up to version 5.8.0 of WooCommerce.

1.0.41

  • Tested up to version 5.7 of WordPress.
  • Tested up to version 5.1.0 of WooCommerce.
  • Tested up to version 8.0 of PHP.

1.0.4

  • Increased max char number for foreign customers

1.0.3

  • Added settings button to the plugins page, under plugin name.

1.0.0

  • Initial release