该插件尚未通过WordPress的最新3个主要版本进行测试。 当与较新版本的WordPress一起使用时,可能不再受到维护或支持,并且可能会存在兼容性问题。

Frontier Restrict Backend

描述

Main Features

  • Users without the capability manage_options (Administrators) will not have access to the backend (admin area, and will be redirected to the home url).
  • Frontier Restrict Backend allows AJAX call such as upload files, but restricted users will not be allowed to access the backend area.
  • Access level chan be changed using a filter – Please see FAQ to allow authors and above to access the back end

Frontier plugins

安装

  1. ftp the plugin to the /wp-content/plugins/ directory or install it from plugin install on your site
  2. 通过WordPress的“插件”菜单激活插件

常见问题

You can change the level that Frontier Restrict Backend blocks, by applying a filter in your functions.php

Per default all other than admin users are blocked, see below example of how to allow Admins, Editors and Authors.

  • manage_options = Administrators
  • edit_others_posts = Editors
  • publish_posts = Authors
  • edit_posts = Contributors
  • read = Subscribers

// ****- Set restrict to allow Author and above -****
function my_restrict_backend_level($min_allow_capability)
{
return “publish_posts”;
}
add_filter(‘restrict_backend_min_cap’, “my_restrict_backend_level”,10,1);

´
The above mentioned capabilities that are allowed.

评价

阅读所有3条评价

贡献者及开发者

“Frontier Restrict Backend” 是开源软件。 以下人员对此插件做出了贡献。

贡献者

更新日志

1.4.0

  • Tested with WP 5.4

1.3.5

  • Tested with WP 5.2.2 and php 7.2.2

1.3.1

  • Tested with 4.9

1.3.0

  • Fixed issue with Featured image by allowing bypass for async-upload.php & admin-ajax.php

1.2.1

  • Tested with 4.7

1.2.0

  • Added option to control access level from filter – see FAQ .

1.1.0

  • Tested with 4.5
  • Readme update

1.0.3

  • Removed error_log messages

1.0.2

  • Initial release