该插件尚未通过WordPress的最新3个主要版本进行测试。 当与较新版本的WordPress一起使用时,可能不再受到维护或支持,并且可能会存在兼容性问题。

📷 Simple QR Code Generator Widget

描述

Very Simple and intuitive QR Code Generator that allows you to place a QR Code widget on your sidebar.

You can set custom QR code image size as well as create QR code for specific urls or content.

Tool is based on Google Chart Tools.

⚠️ Version 2.0 onwards only compatible with latest wordpress installations

屏幕截图

  • The widget settings
  • Widget on the front end

安装

  1. Upload qr-code-generator-widget.php to the /wp-content/plugins/ directory
  2. Activate the plugin through the ‘Plugins’ menu in WordPress
  3. Place QR Code Generator Widget in the widget area

常见问题

Any questions?

评价

此插件暂无评价。

贡献者及开发者

“📷 Simple QR Code Generator Widget” 是开源软件。 以下人员对此插件做出了贡献。

贡献者

将“📷 Simple QR Code Generator Widget”翻译成您的语言。

对开发感兴趣吗?

您可以浏览代码,查看SVN仓库,或通过RSS订阅开发日志。

更新日志

1.0

  • Basic functionality

1.1

  • Links update

1.2

  • Removing deprecated functions

1.3

  • WordPress version 3.9.1 support
  • Renamed widget from widget_qrCode to widget_qr_code. This update will enforce css class update to ‘.widget_qrCode’

1.4

  • WordPress version 4.3.1 support
  • Renamed functions for cosistency
  • Code formatting
  • added sprintf function
  • added support for https sadly Google API is not availible on https 😉

1.5

  • Remove closing tag from end of the plugin to prevent ‘Warning: session_start()’ error

1.6

  • WordPress version 4.6.1 support

1.7

  • WordPress version 4.7 support

1.8

  • Add more validation to user provided values;
  • Add HTML5 range field for width and height; restrict values to integers only; max 450 is to avoid 404 image src errors;
  • Update logic for generating default qr code – it will default to the blog title and Site Address (URL);

1.9

  • Fix reported typo in check for empty url

1.10

  • WordPress version 4.9.1 support
  • Change default url logic; When url is empty, widget will return current page url as qr code

2.0

  • Not backward compatible
  • WordPress version 5.4 support
  • Complete refactor to support new WordPress version

2.1

  • WordPress version 5.8 support

2.2

  • WordPress version 5.9 support

`