该插件尚未通过WordPress的最新3个主要版本进行测试。 当与较新版本的WordPress一起使用时,可能不再受到维护或支持,并且可能会存在兼容性问题。

R3DF Multisite Language Indicator

描述

A plugin that adds language indicators, either a flag, locale or language, beside the site title of sites to help identify similarly
named sites in multilingual multisites. This is most helpful in sites with admin language selectors, where the admin language does not
reflect the site language.

There is a French translation of this plugin included. The French translation was created mostly to test the localization of the plugin.
It’s a “machine” translation, and as a result, not very good. If you can improve it, or provide translations for other languages, please let me know.

屏幕截图

  • Flag indicators.
  • Flag indicators and locale indicators.
  • Language indicator.
  • User profile settings.
  • Plugin options.

安装

The easy way:

  1. To install this plugin, click on “Add New” on the plugins page in your WordPress dashboard.
  2. Search for “R3DF Multisite Language Indicator”, click install when it’s found.
  3. Activate the plugin through the ‘Plugins’ menu in WordPress.
  4. Configure the plugin in the settings page.

The hard way:

  1. Download the latest r3df-multisite-language-indicator.zip from wordpress.org
  2. Upload r3df-dashboard-language.zip to the /wp-content/plugins/ folder on your web server
  3. Uncompress r3df-multisite-language-indicator.zip (delete r3df-multisite-language-indicator.zip after it’s uncompressed)
  4. Activate the plugin through the ‘Plugins’ menu in WordPress
  5. Configure the plugin in the settings page.

评价

此插件暂无评价。

贡献者及开发者

“R3DF Multisite Language Indicator” 是开源软件。 以下人员对此插件做出了贡献。

贡献者

「R3DF Multisite Language Indicator」插件已被翻译至 1 种本地化语言。 感谢所有译者为本插件所做的贡献。

将“R3DF Multisite Language Indicator”翻译成您的语言。

对开发感兴趣吗?

您可以浏览代码,查看SVN仓库,或通过RSS订阅开发日志

更新日志

Version 1.0.12

  • Replaced the deprecated function wp_get_sites() in uninstall – REQUIRES WordPress 4.6+
  • No functionality changes, use 1.0.10 for WP < 4.6

Version 1.0.11

  • Replaced the deprecated function wp_get_sites() – REQUIRES WordPress 4.6+
  • No functionality changes, use 1.0.10 for WP < 4.6

Version 1.0.10

  • More internationalization updates

Version 1.0.9

  • A couple of minor fixes
  • Language file updates

Version 1.0.8

  • Code improvements
  • A couple of minor fixes
  • Language file updates

Version 1.0.7

  • Language file updates

Version 1.0.6

  • Reverted shortform ternary operator incompatible with php 5.2

Version 1.0.5

  • moved user options to user profile page
  • fixed bug which added extraneous flag to toolbar if user was not a part of a site
  • fixed bugs in uninstall

Version 1.0.4

  • Options refactoring – switched display options to user

Version 1.0.3

  • Options refactoring – made most of them global

Version 1.0.2

  • Reverted shortform ternary operators incompatible with php 5.2

Version 1.0.1

  • Code refactoring

Version 1.0.0

  • initial release