Easy Language

描述

Simplify your website into easy language – supported by AI.

The Plugin Easy Language adds the functionality to simplify and display your pages and posts into easy or plain language. The translation process can be manually or support by an AI-engine.

Automatic simplification with AI

To auto-translate your text, you can use the service (API) from

Requirements

If you want to use SUMM AI, capito or ChatGpt you need an API key for their respective API. Please contact their websites for more information.

Highlights

With capito and SUMM AI it is possible to simplify up to 9000 characters FREE OF CHARGE. An API key is required for Capito.

Features

  • Simplify German pages and blog posts into German easy or plain language (Supports German formal too)
  • Simplify selected pages or post one by one
  • Auto-simplify using the API of SUMM AI, capito or OpenAI (ChatGPT)
  • Edit the pages or post manually
  • Add a language switcher by shortcode at any position on your website
  • Multisite support
  • Own role for users to only simplify texts

Compatible with multilingual-plugins

  • WPML
  • Polylang
  • Sublanguage
  • TranslatePress

Compatible with major page builders

  • Block Editor (Gutenberg)
  • Avada
  • Elementor
  • Divi
  • WPBakery
  • Themify

Please Note: The plugin was tested in a broad variety of WordPress-pages, but we highly recommend to install and test the plugin in a development environment first.

The development repository is on GitHub.

the Pro license includes:

  • Support for English (simplify to easy or plain language)
  • Support for French (simplify to FALC)
  • Support for more post-types, e.g. for WooCommerce
  • Support for any taxonomies (e.g. category descriptions)
  • Simplification of single texts
  • Show where any simplified text is used in your website

More details: laolaweb.com/en/plugins/easy-language-for-wordpress/

屏幕截图

  • Choose your API
  • Configure your SUMM AI API Key
  • Request simplification of a text

区块

该插件提供了2个区块.

  • Language Switcher Provides a Block for Language Switcher in navigation.
  • Language Switcher Provides a Block for Language Switcher.

安装

  1. Upload “easy-language” to the “/wp-content/plugins/” directory.
  2. Activate the plugin through the “Plugins” menu in WordPress.
  3. Go to the plugins settings and choose the API you want to use.
  4. Start to simplify your website.

评价

此插件暂无评价。

贡献者及开发者

“Easy Language” 是开源软件。 以下人员对此插件做出了贡献。

贡献者

「Easy Language」插件已被翻译至 3 种本地化语言。 感谢所有译者为本插件所做的贡献。

将“Easy Language”翻译成您的语言。

对开发感兴趣吗?

您可以浏览代码,查看SVN仓库,或通过RSS订阅开发日志

更新日志

1.0.0

  • Initial release

2.0.0

  • Plugin completely revised
  • Added simplification for posts and pages in Einfache or Leichte Sprache, manually or automatic
  • Added support for API-based simplifications via SUMM AI and capito
  • Added support for different source and target languages
  • Added support for different PageBuilder (Block Editor, Classic Editor)
  • Added multiple hooks
  • Extended support for simplifications with TranslatePress
  • WordPress Coding Standard 3.0 compatible

2.0.1

  • Removed language files from release
  • Fixed usage of language-columns in post-types (was only a problem if Pro-plugin is used with other languages)

2.0.2

  • Added more hooks
  • Optimized output of flags
  • Optimized some codes
  • Fixed missing language mappings for SUMM AI simplifications for austria and suisse
  • Fixed missing flag-icons for capito languages
  • Fixed missing API-value for target language on capito
  • Fixed some typos

2.0.3

  • Added automatic generated hook documentation
  • Optimized same text-descriptions
  • Fixed missing translation output
  • Fixed wrong defined WP Bakery hook for HTML-widgets

2.0.4

  • Fixed autoloader-generation

2.0.5

  • Compatibility with WordPress 6.5
  • Updated dependencies for Gutenberg-scripts

2.1.0

  • Added rate us hint on settings page
  • WordPress Coding Standard 3.1 compatible and each release must pass this
  • Log-format for requests to SUMM AI and capito changed to JSON
  • Help and support pages are not linked language-dependent
  • Changed minimum interval from minutely to 10-minutely to match WordPress-requirements
  • Migrating interval from old to new value of 10-minutely
  • Compatibility with WordPress 6.5.2
  • Updated dependencies for Gutenberg-scripts

2.1.1

  • Compatibility with WordPress 6.6
  • Fixed possible error with SUMM AI settings for languages with used API Key