该插件尚未通过WordPress的最新3个主要版本进行测试。 当与较新版本的WordPress一起使用时,可能不再受到维护或支持,并且可能会存在兼容性问题。

MySQLi database layer

描述

MySQL_* functions is deprecated and this plugin creates a layer to use MySQLi instead. So you don’t get notices when using PHP 5.5

Be sure to read the installation instructions, as this is not a traditional plugin, and on activation you do need to install our database driver by using the settings screen or move manually db.php into your content directory.

安装

  1. Verify that you have MySQLi
  2. Go to the settings page of this plugin and install our driver or just copy db.php to your WordPress content directory (wp-content/ by default)
  3. Done!

评价

2019年6月10日
It saved my day, I was having a hard time running locally an obsolete website with PHP56 and WordPress 3.5.1... placing db.php from this plugin in my wp-content folder worked! Now I don't get anymore the error "Your PHP installation appears to be missing...". Thanks!
2016年9月3日
I was restoring an old WordPress site (v3.7.1) that I haven't touched in over 3 years that on my WAMP server. Even though this plugin hasn't been updated for just as long, it was helpful in fixing the depreciation notices that I was getting for mysqli, thank you.
阅读所有12条评价

贡献者及开发者

“MySQLi database layer” 是开源软件。 以下人员对此插件做出了贡献。

贡献者

将“MySQLi database layer”翻译成您的语言。

对开发感兴趣吗?

您可以浏览代码,查看SVN仓库,或通过RSS订阅开发日志