描述
基于 Redis®¹ 的持久对象缓存后端。支持 Predis、PhpRedis(PECL)、Relay、复制、Sentinel、集群和 WP-CLI。
如需调整连接参数、为缓存键添加前缀或配置复制/集群,请参阅 配置选项。
Object Cache Pro
一款 商业级 Redis®¹ 对象缓存后端。真正可靠、高度优化、完全可定制,并在您最需要的时候提供专属工程师支持。
- 为追求极致性能而重写
- 100% 符合 WordPress API 规范
- 更快的序列化和压缩
- 轻松调试 & 记录日志
- 缓存预取和分析
- 完整的单元测试(100% 代码覆盖率)
- 通过 TLS 实现安全连接
- 通过 WordPress & WP CLI 进行健康检查
- 针对 WooCommerce、Jetpack & Yoast SEO 进行了优化
进一步了解 Object Cache Pro。
¹ Redis 是 Redis Ltd. 的注册商标,其相关权利均由 Redis Ltd. 保留。Redis Object Cache 对该商标的任何使用均仅作指称之用,并不表示 Redis 与 Redis Object Cache 之间存在任何赞助、认可或从属关系。
故障排除
您可以在 常问问题 中找到常见问题的解答以及常见错误的排查方法。查阅这些内容总比在支持论坛中等待回复要快。
配置
本插件提供了丰富的 配置选项 和 连接示例。高级用户可参阅 扩展与复制
WP CLI 命令
Redis Object Cache 提供了多个 WP CLI 命令,安装插件后运行 wp help redis 即可了解更多信息。
安装
如需详细的安装步骤,请阅读完整的 安装说明。
评价
贡献者及开发者
更新日志
3.0.0
- 允许将 Predis v3.0 作为 Composer 依赖项
- 将捆绑的 Predis 库升级至 v2.4.1
- 将 ApexCharts 升级至 v4.7.0
- 通过
WP_REDIS_DISABLED常量停用缓存时显示相应提示 - 添加了
WP_REDIS_CHART_COLOR常量 - 添加了
WP_REDIS_LOAD_APEXCHARTS常量 - 修复了
wp_cache_replace()会写入不存在的键并误报结果的问题 - 修复了批量缓存方法使连接卡在管道模式中的问题
- 修复了 PhpRedis/Relay 连接忽略
WP_REDIS_USERNAME的问题 - 修复了未配置密码时
WP_REDIS_USERNAME被忽略的问题 - 修复了空
WP_REDIS_PASSWORD值的处理问题 - 修复了将
WP_REDIS_USERNAME与低于 v5.3.0 的 PhpRedis 一起使用时分片连接出错的问题 - 修复了集群连接的诊断信息中缺少用户名的问题
2.8.0
- 启用缓存时删除瞬态数据
- 针对 WordPress 7.x 的样式优化
- 使用 Predis 和集群连接时遵守
WP_REDIS_SSL_CONTEXT - 在 WP CLI 命令中添加了缺失的
redis_object_cache_(disable|update_dropin)钩子 - 修复了
redis_object_cache_enable动作的结果参数
2.7.0
- 调用递增/递减方法时保留键的 TTL
- 更新了
wp_cache_*()函数签名,以与核心保持一致 - 移除了已弃用的 HHVM 支持
- 移除了已弃用的
WP_REDIS_SERIALIZER常量
2.6.5
- 修复了使用 igbinary 时递增/递减缓存值的问题
2.6.4
- 避免出现部分弃用通知
- 修复了递增/递减缓存值的问题
2.6.3
- 在强化插件中改用
E_USER_DEPRECATED代替_doing_it_wrong() - 修复了使用 Credis(已弃用)作为客户端时出现的错误
2.6.2
- 修复了更多 PHP 7.2 heredoc 解析错误
2.6.1
- 修复了 PHP 7.2 中的 heredoc 解析错误
- 修复了对未定义函数
wp_rand()的调用
2.6.0
- 添加了
Primary Branch标头 - 为 script/style 标签添加了
id - 将 Predis 升级至 v2.4.0
- 将 Credis 升级至 v1.17.0
- 标注已测试兼容到 6.8 版本
- 遵循 Plugin Check(PCP)的规范
- 修复了使用序列化器时递增/递减无法正常工作的问题
- 修复了罕见的复制模式问题
- 修复了诊断中的罕见致命错误
2.5.4
- 集群连接遵守
WP_REDIS_SCHEME - 修复了 Predis 和
SentinelReplication连接的问题 - 修复了
admin.cssURL 中的双斜线问题
2.5.3
- 添加了
WP_REDIS_DISABLE_GROUP_FLUSH常量 - 添加了
redis_cache_manager_capability过滤器和WP_REDIS_MANAGER_CAPABILITY常量 - 为 PhpRedis 集群连接添加了
WP_REDIS_SSL_CONTEXT支持 - 修复了 Predis 和集群/复制连接的若干问题
- 修复了
show_error_and_die()中另一个罕见的致命错误
2.5.2
- 在 Lua 清空脚本中遵守
WP_REDIS_FLUSH_TIMEOUT - 改进
DISALLOW_FILE_MODS支持 - 还原了对
sanitize_key_part()的行为更改 - 再次修复了
show_error_and_die()中罕见的致命错误
2.5.1
- 为诊断添加了超时
- 支持未安装
sockets扩展的少数 PHP 环境 - 修复了
show_error_and_die()中罕见的致命错误 - 修复了
sanitize_key_part()中的弃用通知
2.5.0
- 需要 WordPress 4.6 或更高版本
- 仅在需要时加载文本域
- 添加了
WP_REDIS_DISABLE_DROPIN_CHECK常量 - 遵守
file_mod_allowed过滤器和DISALLOW_FILE_MODS常量 - 将测试文件
.redis-write-test.tmp重命名为object-cache.tmp - 在
wp_die()之前调用redis_object_cache_error动作 - 允许在其他地方定义
WP_REDIS_PLUGIN_PATH - 添加了实验性的清空超时(默认为
5秒) - 移除了不必要的默认忽略组
2.4.4
- 改进了对意外事务结果的处理
2.4.3
- 修正了 PHP
<=7.2语法错误 - 修复了错误页面翻译的加载问题
2.4.2
- 使工具栏脚本更加健壮
- 改进了
redis-error.php中的恢复说明 - 改进 CloudLinux 检测
- 本地化改进
- 防止 W3 Total Cache 和 LiteSpeed Cache 覆盖强化插件
- 修复了使用 Predis 和数组语法时对 ACL 用户名的支持
2.4.1
- 修复 PHP
<=7.2语法错误
2.4.0
- 切换对象缓存时清空缓存
- 当 Redis 无法访问时显示自定义错误信息
- 当 Redis 无法访问时,不允许启用对象缓存
- 弃用了有风险的
WP_REDIS_SERIALIZER配置常量,请改用WP_REDIS_IGBINARY - 使用 Predis 时支持
WP_REDIS_USERNAME - 在工具栏节点中显示缓存命中率的小数位
- 显示
WP_REDIS_SERVERS时隐藏敏感信息 - 改进了与 CloudLinux Accelerate WP 的兼容性
- 工具栏中的清空缓存功能现已改用 AJAX
2.3.0
- 仅向管理员显示仪表盘小工具
- 添加了工具栏节点(可通过
WP_REDIS_DISABLE_ADMINBAR停用) - 添加了
WP_REDIS_SSL_CONTEXT配置常量 - 连接错误时抛出错误
- 添加了使用 Predis 时对用户名的支持
- 添加了对从
WP_REDIS_PLUGIN_PATH加载 Predis 的支持 - 使 Predis 的 Unix socket 连接更加严格
- 修复了按组清空缓存时的罕见 Bug
- 修复了使用 Predis 时的集群 ping 问题
- 将 Predis 更新至 v2.1.2
- 改进了文档
2.2.4
- 延后注册
wp redisCLI 命令 - 不再与 Object Cache Pro 争用
wp redis命令 - 防止 Perflab 覆盖对象缓存强化插件
- 将 Predis 更新至 v2.1.1
- 避免事务失败时出现类型错误
- 检查不兼容的内容类型标头
2.2.3
- 添加了对
wp_cache_flush_group()的支持 - 将 Credis 更新至 v1.14.0
- 移除了
wp_cache_flush()的$delay参数 - 防止诊断功能在读取连接错误时出现罕见错误
2.2.2
- 使用
QM_Data_Cache代替QM_Data - 修复了
WP_Erroruse 语句的非复合名称警告
2.2.1
- 添加了 WordPress 6.1 引入的
wp_cache_supports()函数 - 将 Predis 更新至 v2.0.3
- 避免在
WP_Object_Cache::get()中过早调用microtime() - 支持 Query Monitor 新增的
QM_Data类 - 当管道返回意外结果时抛出异常
2.2.0
- 添加了
redis_cache_add_non_persistent_groups过滤器 - 修复了
wp_add_dashboard_widget的参数 - 修复了 Predis v2.0 下
WP_REDIS_SERVERS的复制问题 - 修复了对
WP_REDIS_CLUSTER字符串值的支持 - 修复了
get_multiple()调用中MGET失败时的问题 - 修复了管道故障时的几个警告
2.1.6
- 修复了 SVN 不一致的问题
2.1.5
- 修复了
is_predis()调用
2.1.4
- 添加了
is_predis()帮助程序
2.1.3
- 修复了
wp_cache_add_multiple()和wp_cache_set_multiple()中的 Bug
2.1.2
- 修复并改进了
wp_cache_*_multiple()的逻辑 - 在
wp_cache_set_multiple()中调用redis_object_cache_set动作 - 在
wp_cache_delete_multiple()中调用redis_object_cache_delete动作 - 检查原始组名(而非清理后的名称)是否被忽略
- 移除了追踪功能
2.1.1
- 将 PHP 版本要求提升至 7.2
- 将
WP_REDIS_DIR重命名为WP_REDIS_PLUGIN_DIR - 修复了诊断中罕见的致命错误
- 允许通过 Composer 安装 Predis v1.1
- 支持将
WP_REDIS_CLUSTER设为字符串
2.1.0
- 将 PHP 版本要求提升至 7.0
- 弃用了 Credis 和 HHVM 客户端
- 将 Predis 更新至 v2.0.0
- 将 Credis 更新至 v1.13.1
- 改进了诊断中集群信息的可读性
- 改进了集群连接
- 修复了连接后 ping 集群的问题
- 修复了
connect_using_credis()中的若干 Bug
2.0.26
- 修复了使用 Predis 时
wp_cache_delete_multiple()中的一个 Bug - 修复了暂停添加缓存时
wp_cache_add_multiple()中的一个 Bug
2.0.25
- 移除了存在问题的
wp_cache_add_multiple()函数
2.0.24
- 改进指标标签/工具提示格式
- 修复了指标图表无法渲染的问题
- 将 Predis 更新至 v1.1.10
- 将 Credis 更新至 v1.13.0
- 支持
composer/installersv1 和 v2 - 检测到外部强化插件时显示设置页面链接
- 添加了
wp_cache_flush_runtime()函数 - 添加了
wp_cache_add_multiple()函数 - 添加了
wp_cache_delete_multiple()函数
2.0.23
- 添加了对 Relay 的支持
- 细微的 UX 修复和改进
- 修复了 PHP 8.1 弃用通知
- 将 ApexCharts 更新至 v3.31.0
2.0.22
- PHP 8.1 兼容性修复
- 升级至 Predis v1.1.9
- 为小工具添加了设置链接
- 全面改进了诊断面板
- 将 ApexCharts 更新至 v3.30.0
- 启用后重定向至插件设置
- 修复了
diagnostics.php文件路径错误的问题 - 修复了设置标签页中的图表溢出问题
- 修复了 Predis 集群 ping 问题
- 避免在内容文件夹不可写时发出警告
2.0.21
- 添加了指标诊断
- 添加了
WP_Object_Cache::decr()别名 - 移动了
diagnostics.php文件
2.0.20
- 修复 wp.org 发布版本
2.0.19
- 使指标标识符唯一
- 为托管在 Cloudways 上的站点设置唯一前缀
- 当
WP_CLI为true时不输出 HTML 调试注释
2.0.18
- 添加了
redis_object_cache_trace动作和WP_REDIS_TRACE常量 - 将 ApexCharts 更新至 v3.26.0
- 修复了
WP_REDIS_DISABLE_METRICS的问题
2.0.17
- 代码清理
- 修复了指标缺失的问题
- 修复了文件系统测试
2.0.16
- 将 Credis 更新至 v1.11.4
- 修复了强化插件通知的样式
- 将指标移至专用类
- 添加了
redis_cache_validate_dropin过滤器 - 使用
WP_DEBUG_DISPLAY常量(而不是WP_DEBUG常量)显示调试信息 - 修复了
wp_cache_get_multiple()中的罕见错误 - 移除了
intval()的用法
2.0.15
- 由于多站点环境中的问题,还原了
build_key()的更改
2.0.14
- 使 Object Cache Pro 卡片支持翻译
- 在诊断信息中添加了
WP_REDIS_SERIALIZER - 提高了
build_key()的速度 - 支持通过环境变量设置
WP_REDIS_PREFIX和WP_REDIS_SELECTIVE_FLUSH - 添加了
WP_REDIS_METRICS_MAX_TIME,用于调整指标的存储时长 - 将文本域和计划任务的加载推迟到
init钩子 - 将捆绑的 Predis 库升级至 v1.1.6
- 防止
connect_using_credis()中的变量引用问题
2.0.13
- 将捆绑的 Predis 库更新至 v1.1.4
- 将
redis-cache设为全局组,以改进多站点上的指标 - 切换到短数组语法
- 已为所有钩子添加
@since标记 - 在强化插件中使用
parse_url()代替wp_parse_url() - 修正了
wp redis status中的插件实例变量名
2.0.12
- 修复了字节指标的计算问题
- 修复了非标准 Predis 配置的问题
- 更好地遵循 WordPress 编码标准
2.0.11
- 修复了使用 Predis 时
wp_cache_get_multiple()中的一个问题 - 防止诊断信息中出现未定义索引的通知
2.0.10
- 修复了
wp_cache_get_multiple()中值的反序列化问题
2.0.9
- 使用颜色突出显示当前指标类型
- 停用指标时显示「指标」标签页
- 重构了连接和 Redis 状态逻辑
- 将 Predis 更新至 v1.1.2
- 移除了 Predis 弃用通知
- 修复了在
wp_cache_get_multiple()中获取派生键的问题
2.0.8
- 修复了因 WP.org SVN 问题导致 2.0.6 和 2.0.7 中标签页无法使用的问题
2.0.7
- 修复了
wp_cache_get_multiple()的问题
2.0.6
- 诊断中添加了实验性文件系统测试
- 重构了设置标签页的逻辑(同时修复了页面跳动问题)
- 修复了
wp_cache_get_multiple()的问题 - 从
wp_cache_delete()返回布尔值 - 使用
redis-cache作为 JS 事件命名空间 - 停用横幅时隐藏小工具中的 Pro 行
- 将
redis_object_cache_get_multi动作重命名为redis_object_cache_get_multiple
2.0.5
2.0 版是对插件的重大重写。请阅读 v2.0.0 发布说明。
- 修复了多站点操作按钮失灵的问题
- 移除了过时的 PHP 5.4 警告
- 为 Credis 添加了
read_timeout支持 - 使用 Credis 时显示连接参数
- 在 Predis 升级通知中添加了 Wiki 链接
2.0.4
- 强化插件过时时,尝试以可靠的方式将其更新
- 在设置页面上显示 ACL 用户名
- 使用
wp redis status显示完整诊断信息 - 复制
object-cache.php时始终设置FS_CHMOD_FILE - 诊断信息中的密码不再对圆点掩码字符进行编码
- 更新强化插件时调用
redis_object_cache_update_dropin
2.0.3
- 停用指标时隐藏「指标」标签页
- 修复了
admin.js在多站点环境中无法加载的问题 - 避免在 Redis 连接已断开时操作指标导致致命错误
- 已添加
WP_Object_Cache::__get()以实现向后兼容性
2.0.2
- 更新了 POT 文件和译者注释
2.0.1
- 支持旧版本的 Query Monitor
- 使「强化插件」状态信息更有帮助
- 当 Redis 版本不可用时,在设置中隐藏 Redis 版本
- 使用
composer-custom-directory-installer包简化了依赖路径 - 防止
QM_Collector与其他插件冲突 - 防止缓存不可用时出现指标问题
- 修复了插件列表中的「设置」链接
- 修正了
WP_REDIS_DISABLED逻辑
2.0.0
2.0 版是一次重大重写。插件现在需要 PHP 5.6,就像 WordPress 5.2 一样。
GitHub 和 Composer 仓库已从 tillkruss/redis-cache 移至 rhubarbgroup/redis-cache。
在多站点网络中,升级到 v2.x 后,请务必「在全网络启用」本插件。
- 要求 PHP 5.6
- 插件现为「仅限网络」插件
- 转而采用 WPCS 编码标准
- 全面改进了设置页面
- 添加了对象缓存指标(显示在仪表盘小工具和设置中)
- 添加了对 Query Monitor 的支持
- 在所有文件中添加了
Rhubarb\RedisCache命名空间 - 添加了对 WP 5.5 新增的
wp_cache_get_multi()函数的支持 - 添加了用于获取插件实例的
redis_object_cache()函数 - 在网络仪表盘中添加了强化插件警告
- 添加了对设置 Sentinel 数据库编号的支持
- 支持 Redis 6 ACL 用户名和密码验证
- 支持在设置页面上覆盖现有的强化插件
- 使用单例模式实例化插件
- 使用 Composer 安装和加载 Predis
- 更新插件时同时更新对象缓存强化插件
- 为每种客户端使用独立的连接方法
- 移除了
CUSTOM_USER_TABLE和CUSTOM_USER_META_TABLE的古怪逻辑 - 将
themes添加为忽略组 - 将默认连接和读取超时更改为 1 秒
- 防止
add_or_replace()中出现竞态条件 - 为清晰起见,将
WP_CACHE_KEY_SALT重命名为WP_REDIS_PREFIX - 将术语「slave」替换为「replica」
- 仅在数据库不为
0时执行SELECT
1.6.1
- 修复了在 AJAX 请求期间显示页脚注释的问题
1.6.0
- 改进了组名清理(感谢 @naxvog)
- 防止替换外部强化插件时出现致命错误
- 添加了包含可选调试信息的 HTML 页脚注释
- 移除了前缀建议
HTML 页脚注释仅在启用 WP_DEBUG 时输出调试信息。如需完全停用该注释,请将 WP_REDIS_DISABLE_COMMENT 常量设置为 true。
1.5.9
- 修复了构造函数中缺少的
$info变量赋值 - 修复了 MaxTTL 警告的触发条件
- 改用默认按钮样式
1.5.8
- 添加了有关无效 MaxTTL 的警告消息
- 添加了有关 Predis 库已停止维护的警告
- 添加了有关更短、易于阅读的前缀的建议
- 在设置中添加了对 Redis Cache Pro 的兼容
- 修复了前缀包含特殊字符时清空缓存的问题
- 修复了使用集群时调用 Redis
INFO的问题 - 稍微清理了一下设置
1.5.7
- 添加了对 PhpRedis TLS 连接的支持
- 添加了在使用 PhpRedis 集群时对超时、读取超时和密码的支持
- 修复了
INFO命令的问题 - 修复了设置缓存键时的对象克隆问题
1.5.6
- 将对象克隆添加到内存缓存中
- 修正了与
read_timeout参数相关的 PHP 通知
1.5.5
将强化插件更新至 v1.5.5 后,请清空对象缓存,以免失效的键占满 Redis 内存。
- 移除了键的小写转换
- 移除了指标的计划事件
- 修复了使用复制时获取 Redis 版本的问题
1.5.4
- 移除了指标
1.5.3
- 已修复:调用未定义的函数
get_plugin_data() - 已修复:调用未定义的方法
WP_Object_Cache::redis_version()
1.5.2
- 在诊断信息中添加了 Redis 版本
- 添加了
WP_REDIS_DISABLE_BANNERS常量,用于停用推广信息 - 修复了
redis.replicate_commands()的一个问题
1.5.1
今天(11 月 14 日)是本插件的 5 周年纪念日,正适合在今天一并发布商业版。
Object Cache Pro 是本插件面向中小企业的重写版本,真正可靠、高度优化且易于调试。
- 为动作添加了执行时间
- 已添加
WP_REDIS_VERSION常量 - 修复了 PhpRedis v3 的兼容性问题
- 修复了选择性清空的问题
- 修复了
mb_*函数不存在的问题 - 将 Email Address Encoder 卡片替换为 Redis Cache Pro 卡片
- 收集版本指标以做出更好的决策
1.5.0
由于 Predis 已不再维护,强烈建议您改用 PhpRedis(Redis PECL 扩展)。
- 改进了 Redis 键名生成器
- 添加了对 PhpRedis 序列化器的支持
- 已添加
redis_object_cache_error动作 - 添加了超时、读取超时和重试配置
- 添加了不可清空的组(默认为
['userlogins']) - 修复了服务器列表中不显示密码的问题
1.4.3
- 要求 PHP 5.4 或更高版本
- 诊断信息改用美化格式输出
- 缺少 Redis 库时抛出异常
- 修复了部分用户无法清空缓存的问题
- 修复了
WP_REDIS_DISABLED为false时管理后台出现的问题
1.4.2
- 添加了 Redis 故障时的优雅降级处理及
WP_REDIS_GRACEFUL常量 - 改进了集群支持
- 已添加
redis_cache_expiration过滤器 - 将
redis_object_cache_get过滤器重命名为redis_object_cache_get_value
1.4.1
- 修正了与
wp_suspend_cache_addition()有关的潜在致命错误
1.4.0
- 添加了对 igbinary 的支持
- 已添加对
wp_suspend_cache_addition()的支持
1.3.9
- 修复了
WP_REDIS_SHARDS在服务器列表中不显示的问题 - 修复了
WP_REDIS_SHARDS在使用 PECL 扩展时不起作用的问题 - 移除
WP_REDIS_SCHEME和WP_REDIS_PATH遗留内容
1.3.8
- 从单文件版 Predis 切换为完整库
1.3.7
- 恢复使用单文件版 Predis
1.3.6
- 新增对 Redis Sentinel 的支持
- 添加了共享支持
- 改用 PHAR 版本的 Predis
- 改进诊断
- 已添加
WP_REDIS_SELECTIVE_FLUSH - 为
WP_Object_Cache::__construct()添加了$fail_gracefully参数 - 始终强制执行
WP_REDIS_MAXTTL - 将
$selective和$salt传递给redis_object_cache_flush动作 - 不再设置
WP_CACHE_KEY_SALT常量
1.3.5
- 在管理界面中添加了基本诊断
- 已添加
WP_REDIS_DISABLED常量,用于在运行时停用缓存 - 防止出现「无效的插件头」错误
- 从
increment()和decrement()方法返回整数 - 防止多次实例化对象缓存
- 始终用分号分隔缓存键的
prefix和group - 改进了
build_key()的性能 - 仅在已注册回调的情况下应用
redis_object_cache_get过滤器 - 修复了
add_or_replace(),使其仅在缓存键不存在时才设置该键 - 已添加
redis_object_cache_flush动作 - 已添加
redis_object_cache_enable动作 - 已添加
redis_object_cache_disable动作 - 已添加
redis_object_cache_update_dropin动作
1.3.4
- 添加了 WP-CLI 支持
- 显示主机和端口(连接方案为 unix 时除外)
- 更新默认全局组和忽略组
- 启用、停用和卸载时清空缓存
1.3.3
- 更新 Predis 至
v1.1.1 - 已添加
redis_instance()方法 - 已添加
incr()方法别名,以兼容 Batcache - 已添加
WP_REDIS_GLOBAL_GROUPS和WP_REDIS_IGNORED_GROUPS常量 - 已添加
redis_object_cache_delete动作 - 使用
WP_PLUGIN_DIR,并以WP_CONTENT_DIR作为回退 - 使用集群或复制时设置密码
- 在
stats()中显示 Redis 客户端 - 将
$cache的可见性改为公开 - 使用旧的数组语法,以防万一
1.3.2
- 确保
WP_Object_Cache::get()中的$result不是false
1.3.1
- 修复了连接问题
1.3
- 新的管理界面
- 已添加对
wp_cache_get()的$force和$found参数的支持 - 添加了对 Predis 集群和复制的支持
1.2.3
- UI 改进
1.2.2
- 已添加
redis_object_cache_set动作 - 已添加
redis_object_cache_get动作和过滤器 - 防止重复的管理状态消息
- 仅在必要时加载捆绑的 Predis 库
- 使用
WP_CONTENT_DIR常量加载捆绑的 Predis 库 - 更新了
stats()方法的输出,使其与 WordPress 一致
1.2.1
- 已添加
composer.json - 已添加停用和卸载钩子以删除
object-cache.php - 添加了本地序列化函数,以更好地支持
advanced-cache.php - 将捆绑的 Predis 版本更新至
1.0.3 - 使标题结构更加语义化
1.2
- 添加了多站点支持
- 将管理菜单移至设置菜单下
- 修正了
get_redis_client_name()中的 PHP 通知
1.1.1
- 如果使用 HHVM 扩展,则调用
select()和可选的auth()
1.1
- 添加了对 HHVM Redis 扩展的支持
- 添加了对 PECL Redis 扩展的支持
- 已添加
WP_REDIS_CLIENT常量,用于设置首选 Redis 客户端 - 已添加
WP_REDIS_MAXTTL常量,用于强制缓存键过期 - 改进了
add_or_replace()、get()、set()和delete()方法 - 改进了管理页面样式
- 从强化插件中移除了所有国际化/本土化代码
1.0.2
- 添加了「清空缓存」按钮
- 添加了对 UNIX 域套接字的支持
- 显著提高缓存对象检索性能
- 将捆绑的 Predis 库更新至
1.0.1版本
1.0.1
- 加载插件翻译
- 对非管理员用户隐藏全局管理通知
- 防止直接访问
redis-cache.php和admin-page.php文件 - 为「停用对象缓存」按钮添加颜色
- 调用
Predis\Client->connect(),以避免可能出现未捕获的Predis\Connection\ConnectionException
1.0
- 首次发布




